If you’re trying to install PHP 5.5 from one of the many repo’s available in CentOS you may struggle to find a reliable repository that provides the correct packages you require.

Firstly you’ll need to install the remi repositories on your server:

Once you’ve completed this you’ll have access to a new repository called remi-php55. You can utilise this repository to install PHP 5.5 along with a huge amount of other packages provided by this repository.

You will need to call –enablerepo=remi-php55 every time you’re wanting to utilise this repository, for instance:

For instance if you’re wishing to install the required packages for Magento 1 alongside some neat extras you can run:

However if you’re wanting to setup a Magento 2 instance you’ll need the following PHP packages:

Dave Macaulay
Dave Macaulay
I'm an enthusiastic, slightly eccentric Magento developer who bores with the idea of another basic brief.